Website and interface not loading

Hello everyone,
Newbie question here, sorry about this.
I just started tinkering my way about the tool, as I need to create various front-end interfaces for my Airtable databases. Softr looks promising and I wanted to learn more !

However, both the website and the dashboard homepage don’t seem to work well on my computer (I’m using Chrome). It looks like the CSS is not properly loading and the platform is then hard to read. I am sorry that this is not directly softr-related, but would you then have any idea what is causing this ?

Thank you in advance !

1 Like

Hello @Clement! Welcome to the community. There are no wrong questions here!

My first candidate would be to check if some of your enabled Chrome extensions might be malfunctioning the website/app look. Try turning them off all together, and if it works, enable one extension at the time, and check which might be causing the issue.

Hi Jakub,

Thank you for reaching out ! Unfortunately, I tried this and nothing changes :confused:

Hi @Clement this is strange. Let’s try another thing – can you also check in your Chrome incognito mode? You can open it in Google Chrome with Ctrl+Shift+N (Windows), or CMD+Shift+N (Mac)?

Hello Jakub,

Again, thank you for your concern. I tried Incognito mode as well, to no avail.

FYI, this is what the “Studio” homepage looks like



Sorry for slowly running out of ideas. One another is that perhaps css/fonts/images are being blocked by some sort of firewall on your computer, so it doesn’t let the page fully use those.

Do you have an antivirus with firewall settings - perhaps you could check there.

Or again, maybe disabling plugin that could be responsible for blocking web traffic is effectively turned off only upon hard browser restart?

Hello Jakub,

Thanks for your time. After extensive discussions with our cybersecurity service provider, it appeared that some scripts on the website were flagged as malicious and linked to advertisements.
I asked for the website to be whitelisted and everything works now perfectly !

Thank you for sharing @Clement, so happy you found the root cause :slight_smile: !

Hello @Clement , I will be helping a Softr app user with a very similar scenario. Would you be able to share any detail on the scripts that were whitelisted, or how the fix happened (where did the whitelisting occur)?

Thank you,
Paul Harren

Hi Paul,

Unfortunately, I can’t really help you, as the change was made by our IT contractor. I am afraid I don’t really know what script was the cause of this !

I was able to solve it by disabling an AT&T internet feature!

1 Like