Visualization of Org Charts

Hi!! I have a question about the Org Charts. As they do in the example I have found, we must create a variable where the relationships between users are established (Supervisor). However, when viewing the Org Chart, none of the employees appear except for one (which has no “parent” user assigned to it). There are more employees that do not have a “parent” but they do not appear either. And of those employees with a parent assigned, none appear in the preview. I would like to know how I can fix this so that I can see all the nodes in the org chart.

I am using a view with the active employees and in this I have a variable of type “Link to” to the same view I am using and disabling the function “Allow linking to multiple records” so I can use it as a variable that indicates the relationships between employees. Once this is done, I have put that variable in the Relationship field in Softr, but it does not work as I expected. The example that I have followed exactly the same step by step is the one below:

Is the problem coming from the data or from some error when configuring the chart parameters? Thank you!!!

Hey @laurasalgueroo,

It’s difficult to say, will need to have a look at Airtable setup and the URL where you have org charts.

If possible please DM this info to me.

Thanks in advance.

I’ve been working on it. The problem was that I have two instances without parent node (supervisor field empty in this two cases) and that was the reason why I couldn’t see the complete tree of my employees. It is not possible to have two separate trees on the same chart.

I can see that the view doesn’t filter my data from Airtable to Softr and I don’t have any filter option to do this directly in Softr. I thought that if you include a view, the filter would work in both spaces, Softr and Airtable, but it only works in Airtable.
It would be amazing if we have any choice to filter our data using the view of Airtable! :grin:


Thank you! :smiling_face_with_three_hearts:

1 Like

@laurasalgueroo and @Suzie the view should work actually. @laurasalgueroo can you pls check that you don’t have sorting also enabled in Softr ? as Airtable either applies the view or the sorting.

No, I don’t have sorting enabled in Softr :thinking:
I only have a filter to select those employees that have the checkbox empty in the feature Inactive.

Is this still the case? If I have an X Axis of Date Names like (Jan-2023,Feb-2023, etc) I want to make sure the X axis on the chart is sorting correctly. I want to sort on the actual date field (2023-01-01 etc) and present the cleaner format in the softr chart.