UTM Tracking Links Cause Content to Disappear for List Details

We are using a list details block to create a blog and have been using UTM parameters (info at the end of links) to track click traffic. This has worked for us in the past, but as of this week, adding that tracking info seems to cause the text for each page to be invisible. For example:

This link works fine: https://www.scipolnetwork.org/nspn?recordId=rectHbtBuvGWZ9hLh

But the exact same link with tracking info no longer displays the page content: https://www.scipolnetwork.org/nspn?recordId=rectHbtBuvGWZ9hLh?utm_source=softr-community&utm_medium=external&utm_campaign=forum

Any idea what might be causing this? Thanks!

The URL is malformed. The question mark at ?utm_source should be a &.

Thanks, that works in this specific instance but it doesn’t solve the more general problem that we need our links to be stable across time and across the different types of pages on our site. We have two question marks on purpose here because when we are not using list details, we need a question mark in the URL. Example:

This link (?) works: https://www.scipolnetwork.org/scientists4communities?utm_source=softr-community&utm_medium=external&utm_campaign=forum

This link (&) does not: https://www.scipolnetwork.org/scientists4communities&utm_source=softr-community&utm_medium=external&utm_campaign=forum

The double question marks previously worked for us in list details links, but this week that capability broke. I suppose we can use a formula in Airtable to either use a ? or & depending on whether or not the URL already contains a ?, but the main point still stands that we really need our links not to suddenly break when Softr makes an update - all of our previous social media posts and newsletters are now unusable.

I’m going to respond again with some thoughts. Just to be clear I’m responding as a fellow user of Softr, and also as a web developer with 20+ years experience. I’m not a Softr representative!

  1. I suspect it is not actually the case that a URL with two question marks in it actually ever worked. Is it possible that this is the first time you tried appending ?utm... to a URL that has a ?recordId=abc... in it?

  2. It is a normal thing for a web developer who is constructing URLs with text functions (e.g., in an Airtable formula) to have to deal with the logic of whether to append a ? or a &. It’s wonderful when Softr can magically remove the need to take care of stuff like this, but it might not be possible in this situation.

  3. If you really don’t want to deal with that logic, a better approach might be to switch over to using custom slugs, the alternate record ID URL format that does not use a ? in the URL. See the docs for more info on how to do this.

I want to reiterate that whenever possible, Softr should make features like this Just Work™ and remove the need for developers to have to implement their own logic. But sometimes it’s not possible!

We have been using this system consistently for several months and this has always worked with these links in the past. We can certainly move forward with the formula method for future links (in fact I’ve already set this up), but again the primary issue here is that all of our previous list details links (on social media, newsletters, etc.), which used to work, are now broken.

OK, I thought about this some more, and it does seem possible that Softr made a change to their URL parsing code recently. The way their server is acting now is as if the value for recordId parameter on the querystring is missing entirely. Perhaps their URL parser used to be lenient about double question marks and they replaced it with something stricter?

I am also wondering if Google Analytics was incorrectly registering the campaign parameter on those malformed URLs, or whether its URL parser is lenient too. Is that something you can go into Google Analytics and check?

We have been able to track the UTM parameters as normal in Google Analytics - the recordId does not show up there.

Hey guys, the thing is that we have not made any changes in the URL parsing code recently. as @dcoletta mentioned, the URLs with two question marks can not work and this is a restriction coming from the browser’s settings (not that we can enable or disable it).

Another question is, can it be that you used the List Details block without linking it to any other List block (with the Conditional filter), and then added the UTM parameter to the link? In this case, there will be only one ? mark and the setting will work as expected.

1 Like

Hi Marine, thanks for the reply. I understand that the double question marks shouldn’t have worked, but I assure you, they did work. We wondered about this when we first set up these URLs, so we tested them, and they worked. We have past Google Analytics data to prove it. Regardless, I’ve changed our setup so that we won’t have URLs of this structure moving forward.

I will check with the person who manages our Softr setup (I don’t manage this) to see whether it’s possible that anything else changed recently.

@MeredithSchmehl I see, I also checked with the tech team from our side and found out that we have not changed anything there also. But, if you could send a URL with two ?-s, we would be able to give you a deeper insight into how it was working.