User not redirected via make webhook

Hi Folks,

Here’s what I try to achieve:
1 submit a form
2 send data for processing thru OpenAi API
3 update Airtable record
4 redirect user once airtable record updated - I use make as per below scenario:

All steps work well except user is never redirected at the last step.

I used the below custom code provided in another thread here in the pager header in Softr in the form submitted by user:

and here’s my webhook response at last step:

I tried all proposals from different threads but my user never gets redirected even if my airtable record is updated.

Btw in Softr, when I click on form submit, instead of “action” I chose “message” with empty text as proposed in a thread.

Please note that all the Make scenario steps works except the last one which is the webhook response combined with the custom code.

I also tried 302 and Location in webhook response.

Thanks folks!

Another option to consider is using an Airtable view that filters on the chatGPT outcome. There can be failures on chatGPT or it can take a longtime, esp with G4. Then just have a different block with that view showing the result.

@belahmew can you DM me some details so I can try the form ?

Thanks Artur, DM sent!

Hi Cooper,

Thanks for your proposal however I am not sure I got your point. Can you please elaborate?
How to tell Softr to display the view only after record is created?

What I need is:

  • user submits form thru Softr
  • data processed with Open Ai API
  • record created in Airtable
  • Softr to display content using the record previously created in Airtable

Any thoughts?


I have exactly the same failure in Webhook response redirection too.
I tried 302 and Location in webhook response as well.
Softr didn`t react at all. it stays in form page still.

@Buff did you figure this out? I’m also unable to get Softr to re-direct with a webhook response

same issue here. any luck?

Can you pls DM me a details to check it online ?

Already DMed you months ago but no answer from your side…

Any solutions here ? :pray:

No solution ? Thanks @artur