Uploading attachments doesn't work from Softr to Airtable

Hi Experts,

In my form I have a field where the user can attach a file.
The field is related to an attachment field in Airtable.
When the user uploads the file, everything looks ok.
However after submit the form, the file is not stored in the Airtable corresponding field.

Any tip? anybody already tried uploading from Softr to Airtable?

Didn’t find any thread or Youtube video explaining the attachments mechanism in Softr.


Hi, I never have problem with this before. if you can share your application here, maybe I can help to take a look.

1 Like

Tried many things and came to this conclusion:
Uploading files from signup form to airtable doesn’t work.
Workaround: I skip file upload during signup and ask user to upload via new form :weary:

Hey @belahmew,

I will try to reproduce this on my end and will keep you posted.


Same problem here. It is bug

Hi all,

I managed to reproduce this issue, I will keep you posted once the issue is fixed.

Sorry for the inconvenience.

1 Like

The issue with the file upload has been fixed.

When attaching a file, please use drag and drop option for now, there is an issue with Browse button (this will be fixed in by the end of the next week).


1 Like

Thanks for your prompt reply @Suzie :pray:

I was really impressed by the reactivity in Softr community especially that it was my 1st post :scream:

Any idea whether the browse option has been fixed? Not easy to let new users guess that they have to drag & drop instead…


1 Like

Hey @belahmew,

Thanks for your kind feedback :slight_smile:

This should be fixed now, can you please double check on your end and confirm?

Thanks in advance.

It works, many thanks!


1 Like

Thanks for the update :slight_smile: Welcome