"This page can't load Google Maps correctly"

I just started using Softr today and I’ve been trying to use the Google Maps block; however, I keep getting “This page can’t load Google Maps correctly” and I’m not sure what I’m doing wrong.

I followed the Softr Maps documentation, set up a Google Cloud billing account, linked my credit card, generated the Map API Key, restricted it, and added it to Softr, which shows a green dot, so I assumed it was connected correctly. But it still displays the same error.

Any suggestions would be greatly appreciated.
Thank you so much!

Did you ever find a solution? I’m having the same issue

Sadly not yet.

OK I had luck when I switched to using “Open Street Map” block instead of “Google Map”

Actually I got Google Map to work too. It just doesn’t show in the Preview – only when you’re viewing the live site, which sucks but at least it works

Really? Mine just displays a gray screen with an error message no matter where I’m viewing it from.

I tried using “Open Street Map” but it doesn’t have the dynamic fields that Google Maps does, and those are a huge part of my app.