Text display with Rich text


I open a new topic, I haven’t seen one on this topic but I might have seen wrong.

My issue is simple: I can’t get rid of the quotes when displaying a description stored in Airtable (the field in Airtable is a Lookup based on a Rich text field). Part of the issue lies with Airtable for sure. So seems more like a feature than a bug… But if you can manage to get rid of the quotes, it’s something that could help us.
I witnessed this in a lot of different modules (list, list details, …)

Thanks for your feedback!

1 Like

This problem has been coming up a lot lately in the forums! The quick answer is try adding ””& to the string variables in your formula. Or post the formula here and I can help more directly.

Is there any update on this bug? Rich text formatting from Airtable is still not showing nicely in softr.io

The problem is Airtable is not using proper markdown and in some cases they return broken markdown. We need to see specific example to be able to help case by case

1 Like

For sure. See below:

Airtable Rich Text with (Enable rich text formatting) toggle ON:

Links to Softr Field: rich text

Live page - not display with the rich text formatting from Airtable:


Thanks in advance for your help!

@rebeccajane can you remove the boldness and check ? it’s conflicting with bullet lists. from the Softr displayed image it’s clear Airtable doesn’t maintain proper markdown syntax too there should not be a space

and the space should be even after the double asterisks **

See also if you can fix it in your text. Also if you don’t mind raise this with Airtable so that they hear from more people and perhaps can fix and stick to markdown specification