Table block to only show filled fields

I have a table block where each record has more that 50 fields in it and would like it to only show the fields that have some information on it.

Is there any way around it? Thanks a lot for any help.

@tsallis23 is it going to show one row ?

1 Like

Thanks for reaching out Artur :). It should show one row but without the fields that doesnt have values on. In my example above, the first value shown should be “M&A” followed by “Planejamento Estratégico”.

Once again, thanks again for trying.

Following :eyes:

Here is the suggestion I got from Softr Support (Jakub):

Here are the steps I’d suggest:

  1. Use a List with horizontal cards block, instead of your current block

  2. Use this custom code:

#list1 [data-field-empty-el], #list1 [data-field-empty-wr] { display: none!important; }

You’ll need to replace list1 in your code with your corresponding list block name.

The code needs to be inserted in the respective page Settings > Custom Code > Header section and the updates need to be published afterwards.

It worked perfectly. I would rather have the table but for now I am satisfied.

Yes Artur, It show everything in one row and the only fields that are shown are the ones with info on it.

@tsallis23 seems you were able to address it with CSS ?

It worked with the CSS. Tks for the follow up.

Hi @artur, actuallty the CSS did not work because even though the list only showed the fields that had info on it, it kept the blanck spaces between the field.
For example, the first field had M&A info, followed by 2 fields with no info on it and then IPO, with also info on it.
Instead of showing M&A followed para IPO, it showed M&A, blanck space, blanck space, IPO.
The CSS did not consolidated so I would had a list of the fields with info, it only disapeared cleared the fields with no info.