Sudden bug with window.records

Hello everyone, I had a softr page with scripts that worked perfectly well, and suddenly nothing works, it’s beyond understanding. something changed with airtable? this is a script using a lot of parameters window.records[recordId].record.fields[‘ANAIRTABLEFIELD’]

what’s weird is that I didn’t touch my code, it bugs all of a sudden. did you notice anything on your side?

Thanks :cold_face:

1 Like

In fact it reminds me of all these topics, except that I have not updated my block and my airtable base has not changed here, here and here

Hey @lea,

The team is checking now :slight_smile:

@lea we limited what are the fields being returned. Until we introduce hidden fields in there please map those fields in the details block that you use in custom code

I will try to bring a clear answer for all the community because I did not immediately understand, but @Suzie explained me by the chat. :pray:

The solution is to connect the fields you want to display and press on hide option in Softr studio.

So, you “declare the airtable fields” (with block repetitions ‘List details page with side image’ for example) to allow your script to use window.record

Thanks for this solution, which will only be temporary I guess :timer_clock:

1 Like

I tried this solution but I’m still getting the TypeError: Cannot read properties of undefined.

I’m assuming that the hack was to put a dummy listdetails block on the page and then “declare” all the values their while keeping them hidden?

FYI i’m trying to access a field within my User table which is a lookup table field.

Also tried this solution but I have undefined error as well.

@ej_dadivas can you ping us on support chat with links to page and details so we can check ?