Softr Studio suddenly insanely slow

Hey guys,

Since yesterday, Softr Studio has gotten REALLY slow.
For instance, if I chose a user group for visibility, it takes seconds to perform the action, same with removing a background image, and and and…

Is some update causing this or is this a temporary issue that others are experiencing as well?

It’s really frustrating currently to make changes :smiley:

Big hug,

Same. I switched to Personal Access Tokens yesterday, and I wonder if this is connected to the slowdown?

Hey @Tim_ClimatEU Could you please add as a collaborator to your app and DM me the URL of the page where you are facing slowness?

Same. I think is related to PAT
I did change to it and became slow as well

Thanks for reporting this guys. I’m checking with the team to see if we’re seeing anything on our side. In the meantime, please let us know if anything improves!

Just heard back, PAT should factor into this. Our team is going to check some things on the backend for our studio, but this seems like it would be best suited for our support team at the moment so they can look into it on a case by case basis as we’re not seeing anything widespread.

Also, feel free to post a loom here and we’ll take a look as well. Whatever you prefer.

@Tim_ClimatEU @MarkSchofield @elementttt are you seeing it consistently? If you could share a loom would help and I would also be happy to jump into a call to figure out… we have been using PAT too for some time and don’t think studio slowness could be related to it

Probably is due to PAT. I’m going to check tomorrow switching back to default airtable connection.

But after I switch to PAT, updates on Airtable are taking 10-15 seconds to show on Softr.

It’s extremely slow! Before that was intantaneous


Not sure if it’s PAT, because I changed to normal connection and still slow

1 Like

Have you tried clearing your cache yet? We’re not seeing this widespread so I think it might be unique to your device?

For me, the problem seems to have resolved itself and it stopped two days later.

1 Like

Thanks for keeping us updated, @Tim_ClimatEU and glad to hear that :pray:t4:

1 Like

@elementttt can you share a loom with us ?


Did you disable the user caching in the settings panel of the app? (It’s in the advanced settings).

It is needed to have real time user group change.

1 Like


Yes, here, disable it please

1 Like

now it works!

Thank you!

Probably you guys added user caching as a option recently because I remember it used to work recently and I did not change any settings.

1 Like

Yes it was added like… 3 or 4 months ago. (I actually don’t remember :sweat_smile:) kind of under the hood - there was no communication about it. (Whereas it should have been communicated!).

Anyway, enjoy now!

1 Like

@matthieu_chateau @elementttt I’m not sure user caching could have any impact on Studio itself it only works for published app… Perhaps the thread is not about Studio… I’m confused what the issue is here overall…

@matthieu_chateau we did light comms about it…

I think that the issue brought by @elementttt was not related to the issue brought by Tim. It was just plugged in the thread, thinking that it could have been related.
You can’t see it as the post was deleted (there was a loom video explaining the problem) but it was related to user caching.

Good point about user caching communication. Though my problem with this communication is the other consequence of enabling user caching, for an important number of use cases => Many Softr users woke up one day with a problem of user group not being updated at a correct speed.

It is recommended to have user caching… Unless your app has user group changes occuring live. This should have been added to the communication post + Softr documentation.