Slow or failing SEO indexing

Hi guys. I am super impressed with Softr so far and have built and published my site in hours. Huge fan. But I am just down to one issue, which is that my site is just stubbornly not indexing on Google.

My site is https://colive.pro and if I run a Google search for site:colive.pro or site:https://colive.pro (or any other http / www variation) it returns nothing. I have:

  • added SEO and Social titles and descriptions to all pages (but in any case the fact I cannot find it with a direct URL search suggests that my bad SEO keywording is not the issue)
  • added SEO columns in my Airtable for each list item (ie. SEO:index = 1 etc)
  • verified the domain via DNS in Search Console AND added all four variants of the URL (ie. www, http, https versions) independently
    -added the tracking code of the https colive.pro property in the tracking ID box provided by Softr AND I added the full HTML snippet into my header source code, even though I was told the DNS verification alone should achieve this result anyway

The Search Console says ‘URL is not on Google. This page is not in the index, but not because of an error. See the details below to learn why it wasn’t indexed.’ If I run a Live Test it works, but I have requested indexing from the console like five times, it never works. Other threads on this error from other sites suggest something on the server is blocking the google crawler indexing my site.

Am I just being impatient? Have I done something wrong? Is there an issue with my domain name or content? This is driving me nuts mainly because I don’t know whether this is an issue with Softr, my site, my content or what.

Hey @bryonyh,

Perhaps sometime was needed to be indexed by Google. I check and it is indexed now.

Let me know if you need further help.