Showing in Preview but not when Published

I am working with a new app with about 20 pages and everything is working perfectly except for one single list-detail.
The list-detail is pulling from the user database and the conditional filter is “Email is Logged in User’s Email”
This is working on every other page except for one. The odd thing is that it is showing up on the preview but not on the published page

Here is the preview

Here is the published
(I am getting this error when I try to post “An error occurred: Sorry, new users can only put one embedded media item in a post.”
Ill try to post the Published version as a reply, but you can imagine that everything from
“$7000 in wallet” to the numbers is not showing

Not sure if I am missing something.


Here’s the published version

Before viewing the live page, have you definitely logged-in as the same user (type) that you are viewing as in preview?

100% you can see in the top corner the user is KH in both screenshots.

I did wonder about that!
This must be frustrating you.
Do you have a working list details block on another page, set up with the same logic to reference the logged-in user, so that you could make a copy and use for this page too?

Hey @Harrison.R,

Are you using Airtable or Google Sheets as a datasource?

I tried something like this. I tried copying the blocks to a different page and publish from there and it was the same thing.
The odder thing is that I totally recreated each block from scratch from an even different page… and it worked. The blocks showed up when I published it. But then a few minutes later I refreshed it and they went away again.
I don’t think I even touched anything in that time.

Airtable :heart: