Rich Text Rendering Issue for URLs with Spaces

I’m working with the rich text field in a list with horizontal sliding cards block and I can’t get it to properly display a link that includes spaces (yes, I know this is not ideal url practice, but it’s not my link so I can’t change it). I have tried URI encoding the url (i.e., making the spaces into %20) and it looks correct in Airtable:

Screenshot 2023-05-01 at 12.20.14 PM

And it looks correct when directly editing it in the rich text editor in the update/add record action buttons forms (tried using both the WYSIWYG and Markdown options):

Screenshot 2023-05-01 at 12.22.07 PM

But as soon as I save it, the rich text renders the "%20"s as actual spaces and breaks the link :sob: :

URL to the live page:

@Derek thanks for reporting we will check this.

following this thread for resolution, I am having the exact same issue :frowning: and these are sharepoint file links so they are looong and ugly haha

@Derek is it currently with %20 in your Airtable cell ?

@artur Hmm. This is interesting! I just checked this and even when I add it in the Softr with %20, the cell in airtable renders the url with spaces. If I manual update this in airtable to use %20 then it renders correctly in Softr!

However, this is not really a sustainable solution since I want end users to be able to add these links without accessing Airtable. Still, another piece of the puzzle!

@Derek are they adding this data via Softr (Form or Edit ?) ?

@artur They are adding it in Softr via an Update Record action button.

I’m also having a similar issue. The Toast UI Editor is stripping spaces from text in the WYSIWYG (.toastui-editor-contents) input form, but not the Markdown (.ProseMirror) input form.

@artur any update on this?

@rhinonix and @Derek, this proves to be pretty non-trivial, and no library gives a solution. Markdown spec is not allowing spaces in URLs, and URLs by spec also don’t suppose to have spaces… We would need to put this on hold and revisit it again after some time and see if we can figure out a pragmatic solution.

@artur Appreciate the response. In my case the issue isn’t URLs in Markdown, it is spaces being stripped from sentences in the WYSIWYG input form while typing. Sorry for the confusion.