Redirect_uri_mismatch Error with Google Sign-In on

I’m running into a challenge with integrating Google Sign-In. I’ve set everything up as per the platform’s documentation, but when I test the published instance, I’m greeted with an error message:

“You can’t sign in because this app sent an invalid request. You can try again later, or contact the developer about this issue. Learn more about this error. If you are a developer of this app, see error details. Error 400: redirect_uri_mismatch”

Here’s what I’ve done so far:

  1. Verified the redirect_uri in my OAuth 2.0 request to ensure it matches one of the URIs I’ve registered in the Google Cloud Console.
  2. Checked in the Google Cloud Console under “Authorized redirect URIs” to ensure my URI is listed.
  3. I’ve also ensured the redirect_uri is correctly configured within the platform’s specific settings.
  4. For context, I’m currently testing the live published instance, not a local development setup.

You can test it yourself at

I’d appreciate any insights or advice on how to resolve this. If you need more information to provide assistance, please let me know, and I’ll be happy to share.

1 Like