Google sign-up integration, Custom Domain Set-Up, Preview mode

Hi Softr community,

I’m quite new to setting up a website so please bare with me. If anyone can help with some advice for the following problems I’m facing, I’ll be really grateful:

  1. Custom domain set-up - I’ve connected my custom domain to Softr successfully but the page still doesn’t load. I keep getting an error that the site can’t be reached. I’ve purchased my domain for GoDaddy. I’ve added the CNAME and A to the DNS at GoDaddy, based on the help article, but the site still doesn’t load. What am I missing here :frowning:

  2. Customized sub-domain - I customized my sub-domain for Softr by changing the name and now I can’t publish the site at all. Again, get the error that the site can’t be reached

  3. Sign-in/Sign-up with Google - I’ve followed the steps in the help article but I keep getting an error saying - Access Blocked, this app’s request is invalid… :frowning: Again what am I doing wrong over here

I’d really appreciate a little bit of advice.

Hey Sammy! we are here to help.

Lets start with your list of issues:

  1. Chances are that after you set up your custom domain on the godaddy side, you need to go to softr studio and publish your app one last time. If you don’t do so, then you will get scary security errors and wranings from all browsers.

  2. Are we talking about a different app, or the same you are having issues with custom domain?

  3. It seems like you having white listed your app URL on the google console

1 Like

Hi Acjnas,

Thank you for trying to assist. Here’s an update:

  1. I have published my site several times, but I still get the ‘401-unauthorized’ access’ error. Is there anything else I can do?
  2. We are talking about the same app, but I’m referring to customizing the subdomain provided by Softr
  3. I think if I can solve the first 2 problems, the 3rd one should solve itself. Because if my domain isn’t getting published then whitelisting on google won’t help -

Thank you

If you can’t update the subdomain for your published app, then you better reach to customer support chat.

1 Like

@Sammy did it work out ? for 401 error pls check your page visibility rules please

Hi Artur,

Thank you for following up. You are absolutely right, it was a visibility setting I had to change. Acjnas helped me out with it yesterday via customer support.

Thanks again

1 Like