Error with Calendar: Something went wrong! Please make sure the date format in datasource and in the Softr studio match

When using the Calendar, all of a sudden there is an error: Something went wrong! Please make sure the date format in datasource and in the Softr studio match.

The Start Date and End Date fields have not changed, they are still Date Fields in Airtable with the ‘Friendly’ format and ‘Use time’ option deselected.

What is happening?

Softr support is saying there is nothing wrong (have been added to both airtable base and softr app as contributors / editors / builders) but the issue still persists across both MacOS and Windows10 on Google Chrome.
Like so many date-based issues I have a feeling that this is an issue with the way softr is interpreting the date Locale (we use DD/MM/YYYY) but are using the ‘friendly’ format in Airtable. I am assuming that this locale is not being translated properly into Softr.

Changing the Date format to both US mode on both Airtable and Softr have solved the issue.
Changing the Date format on Airtable to Local and European on Softr have solved the issue also.
Changing the Date format on Airtable to Friendly and to Friendly on Softr has reproduced the issue.

Therefore if you are using Softr Calendar, it is important to note that Softr Assumes (as of a recent update in their back end) that the ‘Friendly’ format on their end is in the US format of ‘MMMM DD, YYYY’.

This means that in order to use Airtable with ‘Friendly’ format dates you will either have to change your Locale settings within Airtable to USA (unthinkable for many users) or NOT to use ‘Friendly’ date but change to ‘Local’ or ‘ISO’.

This is of course frustrating for many users who have team which rely on internal tools having the correctly formatted Dates within their airtable interfaces.

One response would be to simply use an airtable field with the formatted date and utilise that in the Softr Calendar block. This would not work however, since editing the dates cannot be done on a formula field in either Softr or an Airtable interface.

Therefore I would say that this is a bug based on a US-centric coding practice and there should be another field added for Softr Date formats being ‘Friendly-European’ and change the current ‘Friendly’ to ‘Friendly-US’.


I have the same issue in the UK, client wanted a Friendly date and it was working so this is a new issue I would guess

Can confirm, this issue has been introduced recently by either the Softr or Airtable team