Embed Code field type in List has escape characters added by Airtable

Newbie here comparing Softr out to some of the no-code / low-code competitors. I am simply trying to have a list of media elements that people can add to that includes a block for embedding or a link with the common code that most media platforms allow as their “Share” function.

Either Softr or Airtable, or the integration between them, is causing the

Example: in Youtube click “Share” → “Embed” you will get code such as the following:

When I save this to an Airtable long text column (with Rich Text turned on or off), I get the following in the column, which when returned back to the list is not a valid Embed Code:

<iframe width=“560” height=“315” src=“YouTube” title=“YouTube video player” frameborder=“0” allow=“accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture; web-share” allowfullscreen></iframe>

So all of the opening ‘<’ have changed to escape characters.

I have tried all types of fields in the Actions - Add Record section of the List (Text, Long Text, Rich Text), they all get the same result.

If I copy/paste the embed code directly into the Airtable column the code is correct, so it is happening either in Softr or in the conversation with Airtable.

Hey @rec, can you please let me know which field setting in Softr you are using when you link your AIrtable to the Softr block?

In the List I am using Embed Type:

In the Add Record of Actions for the List I am using Text but get the same results with Long text and Rich text (I have tried all of the combinations of field type on boths Softr and Airtable side):

Thanks for the screenshots @rec. I have one more question: did you configure the edit/update action button on the “Embed Code” block in Softr? I mean when your app users press to edit/update the fields, do you allow them to edit the mentioned field as well?

Yes, there I tried an Edit feature also. The edit form takes a well formed Embed Object (entered directly into Airtable) and mangles it in the same fashion.

That is the case: when you have custom code in an Airtable column and allow your users to edit it, in order not to have any malicious pieces of code added to your database, the system will automatically add the mentioned symbol to the code to make it non-workable. This is not a but how the app works. This is why, we recommend not allowing users to edit fields that contain codes.