Duplicate header '#REF!'

Hi, on a list page i keep getting the above error. At first there’s no issue, but after a while i get the error. Any reasons why? I’ve checked the column names, they’re all different.

Hi @theprofessorodk do you see that error in studio or published app? also, what datasource are you using?

Hi @Maria i see the error both in the studio and in the app. I’m using google sheets. While at first there’s actually no problem.

Can you please, send me a published page link so that I am able to check? If magic link is required you can DM. It shows such error message usually when there is another column/field with the same name in your sheet.

Hi Maria,

Here’s the link: https://smd.softr.app/list

It’s not much of an app because i keep stumbling over the error.

I checked my sheet and there are no double columns.

Maria, i found the problem… i had a column “Dag” and another column “Dag getal”. Removing ‘dag’ from the column did solve the #REF error.

Hi @theprofessorodk actually it shouldn’t consider it as a duplicate. Perhaps you had Dag before and renamed it later but didn’t reconnect the datasource on the block so that it is updated?

Maria, the same problem appeared when i made a copy of my sheet and made a new list in softr. But, for me… the problem is solved.

That is quite unusual. I couldn’t reproduce the issue and it worked normally for me but If happens again please, post here or contact us at support@softr.io and we will investigate. :raised_hands: