Custom domain from hostinger routed to cloudfare - unable to connect

Hi Community,

I am new to Softr and built my first app. I am having issues with my custom domain. I got a domain from Hostinger and connected it to Softr (the status did show as connected [green]). I then realized I did not have an SSL certificate which was causing the website to be blocked (my bad, I should have purchased with the domain). I then added my site to Cloudflare to enable SSL, followed all their instructions [change the name server in Hostinger, then add the IP of Softr in Cloudflare and wait for more than 24 hours]

I also deleted an additional A point as suggested in another question in the forum here which has also been more than 1 day. Please help me to connect my site to the domain which is also SSL enabled.

PS: One thing I noticed in my Cloudflare DNS settings is even after adding @ for my A type, it gets changed to the actual domain name after saving it. could that be an issue?

First of all, sometime it takes time for domain to be enabled, check on softr dashboard → custome domain if its connected or not

Secondly, you don’t really need ssl with softr, if will be automatically enabled

Hey @adnan Thanks a lot for reaching out, is the domain you are adding called
First you will need to add another, CNAME record, set the host to WWW and the value to and after this you will need to make sure you change your proxy status to DNS only for both records.
And here is a document of how to add the both records.

Hi @Andranik Thanks for the reply. Yes, the domain is I already have one CNAME record added with detials that u have mentioned. Do i need to add again?

Hi @nocode_shad Thanks for the reply. So how do I undo the steps that I have mentioned above & publish my site which has SSL? also, I am on a free softr plan, does that also give SSL?

Thanks for getting back @adnan If you have the CNAME it is good, all you need to do is make sure that the proxy status is set to DNS only also you have an AAAA record please delete it.

@Andranik I don’t have any AAAA record, Also, the snapshot attached above is fine on the proxy status, right?

@adnan you need to toggle off the proxied and make it DNS only such as in the screenshot.

@Andranik Thanks for the help. I have done the necessary. Softr seems to be under maintenance now. Will publish again and see if it works. Thanks again!

Sure @adnan always a pleasure!

@Andranik The site is now live with an SSL. Thank you for the help :slight_smile:

1 Like