Checkbox in Signup form for consent

I’m trying to include a checkbox field in the signup form, to allow the users to optin to receive news and communications. The field can be created and correctly mapped to Airtable checkbox filed.
But even if the field is correctly visible in the site, with its label, once clicked nothing happens, the check does not appear.

Is this expected beheavior? is there any other way to have a optin option for communications?

thanks for your help!

Hi @MarsTech, welcome to the community!

To confirm, you cannot achieve ticked checkbox like on the screenshot below. Is that correct?

Let’s try and troubleshoot:

  1. What browser are you using?
  2. Windows/Mac?
  3. Any adblocks/plugins installed in your browser?
  4. If you’re using browser that supports this, does it happen in incognito/private mode as well?

You can also share the published app link if it’s already published, so we can look at our end.

Hi Jakub,
Thanks a lot for your reply!
The Terms and conditions checkbox is working fine.

What I’m trying to do is to add another checkbox for communications optin (maybe there is a better way to achieve this?)
For that I was trying to add a checkbox field. It is visible but not actionable in the final site.
I’ve tried with Microsoft Edge in normal and private mode (Windows) and also in Safari in my iphone with same result.

Yo can see screenshot here:

The link to the site is this: Haciendo historias

best regards,

I’ve tried in Safari as well, added two line description to additional checkbox, and it works just fine.

It looks like the checkbox is treated as a read-only input on your end, but there’s no such setting in Softr Studio, so I’m not really sure what’s hapenning. One thing that is interesting is that your checkbox is far larger compared the checkbox from terms&services. Did you do anything special to make it larger? Some custom code?

@artur any other troubleshooting ideas?

@MarsTech can you for a brief moment disable Iubenda and check ?

Ok I see I’m doing it differently. My checkbox is different because I’m not usign the terms and conditions option. I included a regular checkbox in the form fields. And that’s probably the reason it is not working.

The option you suggest is much better, to have a second check as part of the terms&services, but I cannot find the way to include this second one. Is it a custom code thing?

Hi. I’ve seen an update in the block to correct this issue.
Now the checkbox is working.

thanks a lot!

1 Like