Cannot visualize Softr users created through the Softr API

Hi Team,

I’ve got an issue using Airtable, Make (Integromat) and Softr.
Using a trigger in Airtable, I’m sending a link to an Airtable form to my users
Upon a submission of the Airtable registration form, I’m using Make to create a user record in my Softr app, and sending a flag back to Airtable to mark it as exported.

My issue
Once the Integromat scenario is successfully finished (it displays as so), I cannot see my record in Softr.
Re-running the same scenario in Make clearly indicates that the record cannot be created in Softr as it already exists.
But I haven’t got any track of it in Softr. Before you ask, my test data switch is off :slight_smile:

Here are the troubleshooting steps I tried so far, thanks to the Slack community.

  • Tried to filter my user list to search for my newly created user in Softr
  • Tried to recreate the issue using a simple CURL command. The same thing happens (User is created, but impossible to visualize it in Softr).

Here’s my scenario in Make:

Thanks for your help !

Dear Emmanuel,

Sorry for the belated response. Do you still have this issue?

Dear Suzie,

Unfortunately I still have the issue but managed to rethink the flow of the user creation.
Using Softr signup form this works perfectly, the user is visible in Softr.

However, I still don’t know why the user is not visible in Softr using the API (either through Make or CURL).

So this is not blocker for me right now, but the issue might be critical if it happens to other users.

Thanks !


Are you following these steps?