Block Visilibity Conditions Not Working

Hello!

I’m having an issue w/ block visibility setttings. I am trying to hide a block if data has been entered by the user about their geographic location. I have the current settings below, but when I preview using a test user with geographic data added, the block still shows up. For reference, the Headquarters Country field in Airtable is a link to another table. I’ve also tried with a lookup field in case the link field would be invalid for some reason.

Any ideas?

Is the block on the details page with a recorded in the URL?

If no then we yet need to add a capability for pages where details block is shown with conditions only then hiding dependent blocks.

Hi Artur,

Thanks for the response. Your answer is a little unclear to me.

What do you mean by “with a recorded in the URL?”

I think Artur was asking if your details block is on a detail page where the record URL is included in the URL? Or are you using the details block on a page that is not normally meant for a “details page”?

Thanks for the clarification. It might be that I am using a details page…

@artur I’m wondering if you have an update on this. I’m having issues making this work with code as well.

On this page, I have several blocks. They are Call To Action, List Detail (x2) and New Table Block (x2). I want these blocks to appear if certain data is missing or not meeting certain required criteria. The “Hide block if” feature is not working based on my testing.

Is this a Softr issue, or is there a way for me to enable hiding blocks based on certain criteria that I’m missing?

Hi @DefyPhysics we launched a new feature this week that allows you to better control visibility on details blocks based on the details fields.

If you haven’t yet, navigate to each of your block visibility settings, and try to configure such with the updated information now available.

Hopefully this solves it for you!

@DefyPhysics How do your users navigate to the mentioned page and how the url looks like ?

This works currently when you go from a list page to a list detail page. Think of going from project lists to specific project details page. Is your use case the same or different

@DefyPhysics have you tried to go into the “Source” tab, apply the filter there, and when filter returns no results : Hide entire block? This has worked for me before.