Inline filter doesn't work with the updated list block

I have a list block with inline filters. One of the inline filters filter by a column of type formula. The formula is an if condition that outputs a range. The options I have set are the exact same as the ranges the formula in Airtable outputs. Yet, the inline filter still doesn’t work. Every time an option is chosen, Softr gives an empty list.

The exact setup used to work perfectly with the older version of the list block. I updated the list, had to build it again from the ground up and it doesn’t work!

Does the fact that the column softr filter by is a formula make any difference? Is this the reason why the filtering doesn’t work?

A screenshot of the inline filter settings for the updated list block:

A screenshot of the inline filter settings for the old list block that works perfectly:

  • Motlaq

@Suzie Can you please help?

Hey @Motlaq1,

I am doing the checkups right now, please give me some short period of time.

I just checked on my end @Motlaq1, it seems to be working when adding the option in Inline Filters manually.

May I ask you to check one more thing? Can you please double check if you have connected the Formula field in Airtable to list block dynamic field? If not, please connect and double check if you still face this issue.

Also, if you could share the URL here, that would be great!

I’m having the same problem with this and can’t figure out why it’s working on some filters but not on others. I don’t want to share the public link here but would like to figure out how to fix it. Thanks! @Suzie

@Motlaq1 What were your settings for syncing this with the data source? Oddly, my dropdowns that this isn’t working on is on similar range fields. Inline filtering works fine on other shorter, text fields. Trying to figure out why this one isn’t working.

Hey @mscroggin,

Please send a magic link in DM, we really need to have a close look or you can contact via live chat.

Hi @Suzie - I just sent a message via DM. Will you be able to post the solution/that the bug is resolved in this thread? In the case that other people have the same issue.

Hi @Suzie (or @artur) are there any updates on this bug? Thanks!

Hey @mscroggin,

I just replied to your message :slight_smile:

Hi @Suzie, this did not address my issue because this is a bug. It feels very frustrating to have bug reports that do not have updates and are implied that they are user error issues. How was the other user’s issue fixed? So that others can take note if they have the same bug occur?

For anyone that is having issues, this bug is still not updated on my end. @Suzie @artur

Hi @artur and @Suzie - this bug is still outstanding. I just found out through chat in support that it IS a bug with the formatting and the commas. This was what I asked about in my original comment nearly three weeks ago. Why does Softr tech rely on its customers to identify, test, and solve bugs? @Mariam

@mscroggin We believe airtable did some changes and it’s affecting some cases when inline filters include comma.

@artur Thanks for sharing! How was the original poster’s issue solved if they also used commas? And why would it change if the old block worked correctly? Is there a timeline on this? We have a page that is not usable until this bug is adequately fixed. @Suzie Thanks!

@mscroggin the issue happens when data contains comma. Airtable wraps the values into quotes like "ToDo, Done" instead of ToDo, Done We have a solution in place that will go live tomorrow I think

@artur Has this not always been the case for Airtable? We have already had to build some workarounds for the quotes/commas thing, but I’m not sure why that’s happening in this situation again. How was the original poster’s issue solved if they also used commas? And why would it change if the old block worked correctly?

Has the solution you mentioned been pushed live and tested? Will the dropdown work for our users who are actively inside of our portal, trying to filter through data?

@Suzie @Mariam @Lizzie_LaCour

Hi, just following up on an update from this bug from more than a month ago. Is this bug being worked on? I feel very frustrated being completely in the dark on when things will be fixed. (Not updated, but fixed so that it works) @artur @Suzie

@mscroggin please check we have released a fix

1 Like

Hi @artur thank you so much! It now finally works for us to roll it out to our customers. Thanks!