Getting rid of the hyphen "-" for blank display field

Hi, is there anyway using either code or formula that can get rid of the hyphen as per below pict shown?

They used to be a pict and a string, but after list details block update, it disappear and should be blank. However, the hyphen showed up instead.

Hope can have a simple way to fix this pain in neck issue.

Tks & Bgds


Hi @twmeric and @dcoletta the provided code is outdated now so instead you can use this one by inserting in Page Settings>Custom Code>Header

<style> [data-field-empty-el], [data-field-empty-wr] { display: none!important; }

It removes dashes from all the dynamic blocks on the page.

Also, you can use

    #list1 [data-field-empty-el], #list1 [data-field-empty-wr] {
        display: none!important;

and replace list1 with the corresponding block name to be applied to a specific block on the page. FYI, currently, If the field doesn’t have any Label( this only refers to non-default fields) and the record is empty the dashes will not appear anymore even without the custom code.


Thanks for the update. I’d suggest deleting the outdated topic I linked to.