Dropdown Multi-Select in form showing OLD data

Hi there, on my app I have a form with a multi-select dropdown.
I’ve updated the options in Softr Studio but when I go the the form as a user, it’s showing very old options that are not currently options in the form builder, and NOT the options that ARE entered as options in Studio.

I’ve tried rebuilding the dropdown and re-adding the options, and still it shows the old option.

I’ve tried pulling up the form in both incognito mode and a different browser, wondering if it was possibly a cookie issue, but the issue persists.

Quick update: the new options have “magically” updated in the form and are now available.
But on adding additional options, those are either failing to push to the live form even though they are published options in the Studio.

Note: I was effectively updating (“Publishing”) the changes each time, but is there a lag in the time it actually takes the changes to populate?


I’m leaving the thread here for now hoping it helps someone similarly, but I think* I figured out what the issue was, and it appears it’s NOT a bug.

Seems I was using a user under “preview mode” where data was not visible (the toggle switch on the User page). TBH I don’t really understand it yet, but I think this was the issue.

1 Like